Files
ports/security/libcryptui/Makefile
T
Dima Panov 6a0795e631 security/libcryptui: unbreak after 29b3afa37e (+)
GnuPG was updated to 2.4.x series and libcryptui cannot recognize it as walid version.
Update post-patch REINPLACE macro to extend allowed range.

==> checking for GPGME - version >= 1.0.0... yes
==> configure: error: Appropriate version of GnuPG not found. Please install one of versions: 1.2 1.4 2.0 2.1 2.2 2.3

Reported by:	poudriere failure
Approved by:	portmgr blanket
2023-07-11 15:39:00 +03:00

46 lines
1.2 KiB
Makefile

PORTNAME= libcryptui
PORTVERSION= 3.12.2
PORTREVISION= 4
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME application for managing encryption keys (PGP, SSH)
WWW= https://gitlab.gnome.org/GNOME/libcryptui
BUILD_DEPENDS= seahorse>=3.0.0:security/seahorse \
gpg:security/gnupg
LIB_DEPENDS= libgpgme.so:security/gpgme \
libdbus-glib-1.so:devel/dbus-glib \
libgnome-keyring.so:security/libgnome-keyring
RUN_DEPENDS= seahorse>=3.0.0:security/seahorse \
gpg:security/gnupg
USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz xorg
USE_GNOME= intlhack gnomeprefix gtk30 introspection:build
USE_XORG= sm ice
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.gnome.seahorse.recipients.gschema.xml
OPTIONS_DEFINE= NOTIFY
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNOTIFY}
LIB_DEPENDS+= libnotify.so:devel/libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
.endif
post-patch:
@${REINPLACE_CMD} -e 's|"1.2 1.4 2.0"|"1.2 1.4 2.0 2.1 2.2 2.3 2.4"|g' \
${WRKSRC}/configure
.include <bsd.port.mk>